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WHAT IS “BREKEL POINTCLOUD” 

 

 

“Brekel PointCloud” is a Windows application that records 3D PointCloud data using a Microsoft Kinect v2, 

Orbbec Astra, Orbbec Astra Pro or Intel RealSense 300/415/435 sensor at 30 frames per second and export 

them to popular mesh- and particle-cache formats. 

 

It is written by Jasper Brekelmans, so in case you’re wondering that’s what “Brekel” refers to. 

“Brekel” is pronounced as “Break–uhl”. 

  



REQUIREMENTS 

 

• Kinect for Windows v2 sensor or Kinect for Xbox One with separately available adapter 

• Orbbec Astra / Astra Pro sensor 

• Intel RealSense 300/415/435 sensor 

• Windows 8 / 8.1 (USB stack of Windows 7 or below can’t handle bandwidth requirements of v2 sensor 

and is NOT supported) 

• USB 3.0 port, Intel and Renesas chipsets only! (others brands may or may not work) 

• DirectX 11 capable GPU (Intel HD4000, AMD Radeon HD6470M / HD6570, NVIDIA Geforce 610M or 

above) 

• 4 GB or more RAM 

• Dual Core 3.1Ghz i7/i5 CPU or equivalent (slower should work but may drop frames) 

• 1280×1024 screen (recommended: 1920×1080 or higher) 

 

Note: when using a Kinect for Xbox One you will need to purchase a separately available power adapter to 

connect it to your PC. 

  



 

LICENSING 

 

With your purchase you should have received a download link for the retail version of the software and an 

email with your license code. (Please allow up to 24 hours for processing your request and double check your 

spam filter) 

 

The retail version will work immediately and with no restrictions even without a valid license, but will need 

activation within 5 days for continued operation. 

 

You can activate your copy by using the “File > Install License” option from the menu. 

 

It will ask you to browse for your license file (which was attached to the mail). 

The license will automatically be copied to your “C:\ProgramData” folder and be active upon restart of the 

application. 

If license installation fails (for example due to user permissions) you also manually extract the .zip file and copy 

the .key file manually to the “C:\ProgramData” folder. 

 

To display the current license info use the “File > Show License Info” option from the menu to display a 

window like the following: 

 

  



 

THE MAIN INTERFACE 

 

The application has  a “Live” and a “File” mode which can be switched from the tabs just above the main 3D 

viewport. 

 

In “Live” mode 3D PointCloud data from the Kinect sensor is visualized and can be recorded to disk in the .BPC 

(Brekel Point Cloud) format. This is a proprietary format is designed to be as efficient as possible. 

 

 

In “File” mode .BPC files can be loaded and converted to the available mesh- and particle cache formats. 

At the same time the video data can be exported to various image texture formats ready for UV mapping. 

 



3D VIEWPORT NAVIGATION 

 

To orbit: 

• Left mouse button, click & drag 

 

To dolly in/out: 

• Middle mouse button, click & drag 

• Shift + Left mouse button, click & drag 

• Mouse wheel 

 

To pan: 

• Right mouse button, click & drag 

• CTRL + Left mouse button, click & drag  



LIVE MODE 

 

 

In Live mode data is collected from the sensor at full resolution and at 30 frames per second. 

 

 

With the “PointCloud”, “Color”, “InfraRed” and “Depth” tabs you can choose which source from the sensor to 

visualize in the main viewport. 

Note that on slow machines displaying full 3D “PointClouds” may be slower to draw than “Video” or “Depth”. 

 

 

Below the 3D view the audio is displayed as a waveform.  



LIVE > POINTCLOUD 

 

 

When viewing the PointCloud in the main window the following  controls appear in the GUI: 

 

Texture Selection, selects how to texture the pointcloud for both visualization and recording 

• None: do not use a texture but visualize white points 

• Color: use the color camera to texture the pointcloud 

• Infrared: use the infrared camera to texture the pointcloud 

• Depth: use a depth gradient to texture the pointcloud, the further away a point is the darker 

Note that Infrared and Depth are sampled from the same lens but Color is not. Color is automatically mapped to compensate for this but 

there may be small artifacts on object edges. 

 

Auto PointSize 

Tries to adjust the size of the points depending on the distance of the camera. (for visualization only) 

 

Floor 

Toggles drawing the floor grid in the viewport. 

 

Frustum 

Toggles drawing  the camera frustum in the viewport to give an indication of the field of view of the sensor. 

  



LIVE > COLOR 

 

This visualizes the color stream of the sensor. 

The resolution is 1920 x 1080, in normal lighting conditions the framerate is 30 frames per second, in low light 

conditions it will automatically switch to 15 frames per second, try manual exposure in that case.  



LIVE > INFRARED 

 

 

This visualizes the InfraRed stream which is the source for the Depth stream (and therefore tracking). 

Internally this extracts all ambient lighting and should provide a very stable image as a base. 

It has a resolution of 512x424 at 30 fps. 

 

Gamma 

Adjusts the gamma of the InfraRed video stream, you can use this to make it lighter/darker. 

 

Regular / Long Exposure 

Regular uses a single exposure frame with as little motion blur as possible but possibly some extra noise. 

Long Exposure internally averages 3 frames (from the raw 300 fps stream) to reduce noise at the cost of 

slightly more motion blur. 

 

Colorize Bodies 

Will color the pixels of detected bodies (up to 6).   



LIVE > DEPTH 

 

 

When selecting the Depth tab the Depth stream is visualized. 

Internally this is calculated from the InfraRed stream and has a resolution of 512x424 at 30 fps. 

In the visualization pixels closer to the camera have a lighter color, pixels further away have a darker color. 

Black pixels indicate that the sensor wasn’t able to measure depth, which can be due to being to close from 

the sensor (< 50cm), too dark, too reflective material, or too light. (for example strong sunlight) 

 

Gamma 

Adjusts the gamma of the Depth stream, you can use this to make it lighter/darker. 

 

Colorize Bodies 

Will color the pixels of detected bodies (up to 6). 

 

  



LIVE > SENSOR 

 

 

 

Synchronize Streams 

Forces the driver to synchronize Color/InfraRed/Depth streams, note that in low lighting situations this can 

mean not only the Color stream but also the InfraRed & Depth streams switch to 15 fps (instead of 30 fps). 

 

Mirror 

Horizontally mirrors the data. 

 

Auto Align with Floor 

Tries to detect the floor and automatically adjust the Position/Rotation fields. 

 

Automatic Exposure 

When turned ON the color camera will automatically adjust exposure depending on the amount of light it sees. 

Note that the color camera is not used for body tracking. 

 

Manual Exposure 

Allows for manual exposure adjustment when Automatic Exposure is turned OFF. 

  



Position 

Adjusting these XYZ values will translate the pointcloud, the main value of interest is the Y value depicting the 

height of the sensor above the floor. 

 

Rotation 

Adjusting these XYZ values will rotate the pointcloud, which can be of use when the sensor is tilted. 

 

Reset Alignment 

Resets the Position and Rotation values back to 0.  



LIVE > CROPPING 

 

 

Enable 

Toggles Cropping, a box will appear in the 3D viewport indicating the cropping area. 

Note that when areas of the pointcloud are cropped out they cannot be retrieved again after recording, but 

recording fewer points will result in smaller file sizes. 

 

X/Y/Z Min/Max 

The extent of the cropping area, in meters, in relation to the sensor. 

  



LIVE > BACKGROUND EXTRACTION 

 

 

Background extraction allows the software to learn what an empty space looks like so that it can use that 

learned information to isolate foreground elements. 

 

State 

Shows the current state of the internal buffers (Empty, Learned or Loaded) 

 

Use 

Toggles if the learned background should be used to isolate foreground pixels or not. 

 

Search Width 

Specifies how many pixels should be compared when determining of a pixel belongs to the background or 

foreground. 

0 uses only the current pixel, which is the fastest but may produce some noise. 

Higher values reduce noise but are slightly slower to process. 

  



 

Start Delay 

Specifies if (when hitting the Learn button) a delay of several seconds should be used before leaning starts. 

This can give you some time to clear the capture space. 

 

Learn Time 

Specifies how long the learning should continue, a value of 0 will simply learn until the Learn button is pressed 

again to stop learning. 

Due to noise in the sensor it’s best to always learn for at least a few seconds 

 

Clear 

Clears the internal buffers. 

 

Load 

Load from file on disk, a custom BBF (Brekel Background File) format is used. 

 

Save 

Save to file on disk, a custom BBF (Brekel Background File) format is used. 

 

Note that if you saved/loaded learned background information to/from a file that the software will 

automatically try to load this when it’s next started. 

  



LIVE > AUDIO 

 

 

Available Devices 

List the available audio devices that can be used for recording and allows you to select one of them. 

 

Number of Channels 

Switches between Mono and Stereo recording. 

 

Sampling Rate 

Sample rate to record (in Hz). 

 

Recording Volume 

Sets the recording volume for the chosen device, see the waveform display below the 3D viewport to check 

that your volume is not too low or high. 

 

Speakers Passthrough 

When enabled will also play back the audio on your speakers. 

 

Note that audio is embedded into the recorded BPC file and can be later converted to a separate audio file if 

desired.  



LIVE > NETWORK 

 

 

Record Triggering 

Allows synchronized recording across multiple Brekel applications. 

One application can be in Primary mode, all others in Secondary or Ignore mode. 

The Primary application will send a signal when recording is started and stopped so all applications start/stop 

at the same time and are using matching filenames. 

Note that this works across multiple apps on the same machine and even across multiple machines on the 

same network. 

 

Make sure your firewall isn’t blocking port 8880-8890. 

  



LIVE > FILENAME 

 

 

Edge Filter 

Helps to remove unwanted points by trimming edge points, unwanted points can be caused due to depth 

sensing and color remapping inaccuracies at edges. 

 

Output Folder 

The folder to which to save the recorded files. 

 

Output Filename 

The name of the output file. 

 

Auto Filename 

When turned ON the filename will be automatically generated using the current date & time. 

  



LIVE > RECORDING 

 

 

 

Hirez Color Mode 

When enabled will record full resolution (1920x1080) color, at the cost of bigger file sized. 

When disabled a lower resolution (512x424) will be used. 

 

Color Compression 

Lossless will result in the best quality but biggest filesize. 

Lossy uses JPEG compression and reduces the file size, but will also introduce some quality loss. 

Depending on the quality setting and contents reductions of 60% in filesize are quite typical. 

 

Color Compression Quality 

1 will produce the best compression but lowest quality 

100 will produce least compression but highest quality 

 

  



Point Compression 

Lossless will result in the best quality but biggest filesize. 

Lossy compression reduces the file size, but will also introduce some (minor) quality loss. 

Depending on the contents reductions of 30% in filesize are quite typical. 

 

With Color & Point Compression enabled filesize reductions of 75% compared to Lossless can typically be 

achieved. Compared to older versions of the software (2.17 and below) this can even be 85-90%! 

 

Start Delay (in secs) 

When bigger than 0 a countdown will start after starting a recording, giving the actor a few seconds to get into 

position before capture will start. 

During countdown beeps will be played over the speakers every second, and the amount of remaining seconds 

will also be shown visually in the 3D window. 

 

Beep at start/stop 

When enabled will play a beeping sound over the speakers when recording starts/stops. 

 

Recorded 

Will display the amount of frames and seconds as well as the average size (in Megabytes) of each frame 

recorded. 

 

Start/Stop Recording 

Toggle button for starting & stopping the recording. 

 

  



FILE MODE 

 

 

In File mode previously recorded .BPC files (Brekel Point Cloud) can be loaded and exported to various mesh 

cache, particle cache and texture output file formats. 

Depending on the chosen format(s) and available CPU and disk speed this is a process that can take a bit of 

time and it is therefore done as a post process. 

 

Note that Brekel Pro Body 2 and Brekel Pro Face 2 have the option of recording a BPC file at the same time as 

tracking the body or face. 

  



FILE > DRAWING SETTINGS 

 

 

 

Auto PointSize 

Tries to adjust the size of the points depending on the distance of the camera. (for visualization only) 

 

Floor 

Toggles drawing the floor grid in the viewport. 

 

Frustrum 

Toggles drawing  the camera frustrum in the viewport to give an indication of the field of view of the sensor. 

 

Use Texture 

Toggles using the video texture when drawing the points/mesh in the viewport. 

  



FILE > FRAME / INPUT / OUTPUT 

 

 

Frame 

After loading a file this allows you to scrub through the recorded sequence. 

 

Input File 

Allows you to specify a previously recorded BPC file (Brekel Point Cloud) to use as a source. 

 

Output Folder 

Allows you to specify an output folder for the various export formats. 

Note that subfolders will automatically be created for the export formats that consist of file sequences. 

When no output folder is specified the folder where the input file resides will be used. 

  



FILE > FILTERING OPTIONS 

 

Fill Small Gaps 

Tries to fill small holes in the data, a value of 2 is usually a good. 

 

Edge Filter 

Removes points on the edges, which can be unwanted due to noise and inaccuracies of color to depth 

mapping, a value of 2 is usually good. 

 

Smooth Points 

Smooths points, this can help in reducing sensor noise. 

 

Decimate 

Values higher than 1 reduce detail by skipping points. 

A value of 2 will only use every other point, a value of 3 only every third etc. 

This will be done for both particle and mesh output. 

  

  



FILE > BACKGROUND SUBSTRACTION 

 

 

Background extraction allows the software to learn what an empty space looks like so that it can use that 

learned information to isolate foreground elements. 

 

State 

Shows the current state of the internal buffers (Empty, Learned or Loaded) 

 

Use 

Toggles if the learned background should be used to isolate foreground pixels or not 

 

Search Width 

Specifies how many pixels should be compared when determining of a pixel belongs to the background or 

foreground. 

0 uses only the current pixel, which is the fastest but may produce some noise. 

Higher values reduce noise but are slightly slower to process. 

 

  



First/Last Frame 

Depicts which part of the current file is considered to represent an empty space, it will use these frames to 

learn from. 

 

Set To Current Frame 

Sets the first/last frame to the current frame on the timeline. 

 

Learn From Current File 

Will go through the selected frames and learn what the empty space looks like based on the data. Note that 

you will see progress indication in the console window. Learning can take several seconds depending on the 

amount of frames specified. 

Clear 

Clears the internal buffers. 

 

Load 

Load from file on disk, a custom BBF (Brekel Background File) format is used. 

 

Save 

Save to file on disk, a custom BBF (Brekel Background File) format is used. 

 

Note that if you saved/loaded learned background information to/from a file that the software will 

automatically try to load this when it’s next started. 

 

 

  



File > Clip Bodies 

 

 

 

During recording the software will automatically tag pixels that belong to human bodies (up to 6 people at a 

time). 

These tags can be used to either remove people or isolate them from the background. 

 

Clip Bodies with ID 0-5 

When a body is recognized on the current frame this will be indicated with the “Detected on current frame” 

text next to one of the IDs. 

To remove the background and isolate one or more people select the IDs you want. 

 

Inverse 

To remove people and only keep the background pixels enable the Inverse option.  



FILE > CROPPING 

 

 

Cropping allows for cutting the sides off to potentially clean background data that is not needed. 

When cropping is enabled a box is drawn in the 3D window visualizing the bounding box of the data that is 

saved. Any points outside of this box will not be drawn and exported. 

 

There is a Pre-Transform and Post-Transform section, these are applied before and after the custom Transform 

settings (see next chapter) 

You can think of Pre-Transform to crop in local space (relative to the sensor). 

And Post-Transform in global space, the bounding boxes in the viewport will also make this clear 

 

Enable 

Turns cropping ON/OFF. 

 

Reset 

Sets the bounding box to the current bounds of the pointcloud. 

 

XYZ Min/Max 

Sets the size of the bounding box as visualized in the 3D window and used during export. 



 

Point Weight (For Reset) 

When this is at 1.0 all points will be used to calculate the bounds when hitting Reset. 

Using a low value can help in skipping small noisy and lonely points on the edges. 

(You usually shouldn’t have to change this value) 

  



 

FILE > TRANSFORM 

 

 

Enable 

Turns transform ON/OFF. 

 

Position 

Allows you to translate the pointcloud in 3D space. 

 

Rotation 

Allows you to rotate the pointcloud in 3D space. 

 

Scale 

 

Allows you to scale the pointcloud in 3D space. 

 

Reset 

Resets all position rotation and scale values to their defaults. 

  



FILE > RANDOMIZE 

 

 

Enable 

Turns point randomization ON/OFF/ 

 

Amount X 

Amount of displacement in X direction 

 

Amount Y 

Amount of displacement in Y direction 

 

Amount Z 

Amount of displacement in Z direction 

  



FILE > GEOMETRY OUTPUT 

 

 

Specifies to which mesh cache formats to write. 

 

Stretch Threshold 

This option will filter out polygons that are stretched in depth above the specified threshold. 

A value that is too high may incorrectly connect objects close to the sensor to those further away from it. 

A value that is too low may create small holes in the mesh. 

 

Notice especially the arms and hands in the following example: 

   

 

Mesh Type 

Generate quads or triangle meshes. 

 

Merge Points 

Merge points or not when generating the mesh. 



Alembic 

Exports all frames to a single Alembic (.ABC) file, this is one of the most efficient file formats for meshes. 

More and more 3D packages support this popular format (Maya, Modo and Nuke for example) but free and 

commercial plugins also exist. You can find links to some of these plugins under the Help menu. 

 

Alembic Compression 

Alembic files can be compressed (lossless) to save disk space, this sets the level of compression. 

Higher values produce smaller files but will be slower to export. 

 

Realflow BIN 

Exports meshes to a sequence of Realflow BIN files. 

You can download free “Connectivity Plug-ins” for most 3D applications from the Realflow website. A direct 

link to their site can be found under the Help menu. 

 

OBJ sequence 

Exports meshes to a sequence of Wavefront OBJ files. 

These files can be read by most 3D applications, but few applications are designed to handle sequences of OBJ 

files efficiently. 

 

MTL files 

This will export an MTL material file along with each OBJ file. (most applications don’t need this but some like 

MegaCache for Unity may do) 

You can select which texture format to write into the MTL file. (note that this will not enable texture export 

automatically, it just writes the path into the MTL file) 

 

  



PLY sequence 

Exports meshes to a sequence of PLY files. 

 

Texture/Colors 

Specifies to export the texture as 

• None, don’t export them at all to keep file sizes smaller 

• Texture Coordinates, also known as UV coordinates so you can map the texture output automatically 

• Vertex Colors, as embedded colors saved per vertex 

 

Flip U/V buttons 

Allow flipping of the U and/or V channel for texturing purposes. 

If textures appear flipped with the default settings experiment what your 3D package prefers. 

  



 

FILE > PARTICLE OUTPUT 

 

 

Compression 

Compression creates smaller files, does not decrease quality, at the expense of writing speed. 

(note that not all file formats support this) 

 

Colors 

Writes textures as per-particle colors for the formats that support it. 

 

Realflow BIN 

Exports particles to a sequence of Realflow BIN files. 

You can download free “Connectivity Plug-ins” for most 3D applications from the Realflow website. A direct 

link to their site can be found under the Help menu. 

  



BGEO 

Exports particles to a sequence of BGEO files (only for use in Houdini versions lower than v12). 

 

PDB 

Exports particles to a sequence of PDB files, for use in Maya and/or other programs. 

 

PDC 

Exports particles to a sequence of PDC files, for use in Maya. 

 

PRT 

Exports particles to a sequence of PRT files, for use in Krakatoa. 

 

PTC 

Exports particles to a sequence of PRT files, for use with Renderman and compliant renderers. 

 

UnityCoder 

Exports to the native file format of the UnityCoder plugins for Unity. 

 

PTS 

Exports to the PTS Leica file format. 

 

  



FILE > TEXTURE OUTPUT 

 

 

JPG 

Exports color information to a sequence of Jpeg files. 

 

PNG 

Exports color information to a sequence of PNG files, optional Compression is lossless. 

 

TGA 

Exports color information to a sequence of TARGA files, optional Compression is lossless using the RLE 

algorithm. 

 

TIFF 

Exports color information to a sequence of TIFF files, optional Compression is lossless using the Deflate 

algorithm. 

 

Video 

Exports the texture as a video file, note that the available codecs are dependent on which ones are installed on 

your machine. 

 

OpenEXR (depth) 

Exports the depth to OpenEXR file format, preserving the full bitdepth and detail. (since this is bigger than any 

8bit file format can store), optional Compression is lossless. 

The value is a multiplier that allows you to keep the depth values in a user specified range. 

  



FILE > AUDIO OUTPUT 

 

WAV 

Exports the audio to WAV (waveform) files. 

Note that this is only available if you recorded audio into your BPC file. 

  



BREKEL REALTIME FILE FORMAT 

 

The BRF file format is a proprietary format specifically for this application, it’s designed for efficiency when 

playing back in realtime applications like game engines for example. 

PointCloud v2 comes with an integration for the Unity game engine. 

 

Note that this format is deprecated in favor of the new Brekel RGBD format (see next chapter) 

BRF will no longer be actively developed on and will be removed in a future version at some point. 

 

BRF (Brekel Realtime File) 

Enables export to BRF files 

 

Compression 

This setting either favors the internal compression for “Fasted load speed & best quality” or “smallest file size”. 

Differences in efficiency are dependent on the contents though. 

 

Color Quality 

Lower values results in better compression and smaller files at the cost of visual quality 

 

Resize Color/Point Width/Height 

These always default to the size of the originally recorded pointcloud but in some cases you may want to 

change these, for example when you’re playing back multiple pointclouds and less quality can give you better 

playback speed. 

 

 

Note: 

The software comes with a Unity integration allowing high speed playback of BRF files as pointclouds or 

meshes, also suitable for Virtual Reality. 

Please check your installation folder for a Unity package file containing C++ plugin, DirectX11 geometry shader, 

integration script and example scene. 

(usually something like “C:\Program Files\Brekel Pro PointCloud 2 x64\Unity3D”) 



BREKEL RGBD FILE FORMAT 

 

The Brekel RGBD file format is designed to encode all data in a regular movie file that can be compressed with 

existing video codecs and can be decoded and played back very efficiently in the Unity game engine. 

Unlike the older BRF file format it does not need a C++ plugin for decoding therefore it should work on all 

platforms that support video playback and geometry shaders. Including AR/MR headsets like Magic Leap and 

HoloLens and most VR headsets. 

 

 

 

Brekel RGBD movie 

Enable this to export a movie file in H264 MP4 format 

 

Auto Range 

Will automatically set the min/max range per frame, this is the recommended (and default) setting 

 

Manual Range 

Allows you to specify the minimum and maximum depth range that will be exported in the file. 

Larger (than necessary) ranges will slightly degrade quality. 

 

Current Frame Min/Max 

Readout of the current’s frame minimum and maximum depth range, can be used as a guide to specify a 

manual range. 

 

Bitrate 

Bitrate of the video codec (in Mbps), higher values produce larger files but with fewer compression artifacts 

 



To use bRGBD files in Unity import the “Brekel_RGBD.unitypackage” package from the installation folder 

(usually something like: “C:\Program Files\Brekel Pro PointCloud 2 x64\Unity3D”) into your Unity project. 

 

Have a look at the accompanying readme and example scene in the unitypackage for reference. 

  



FILE > FRAME / BATCH / EXPORT 

 

 

Resync Dropped Frames 

When enabled will try to resynchronize frames that were dropped during recording by duplicating frames. This 

is done using the internally stored timecodes. 

 

Trim and Recompress 

Converts the current BPC file into a new one allowing you to specify new compression options and start/end 

frames. This can for example be used to extract a smaller clip from a longer recording. 

 

Start/End/Frame 

Depicts which range of the timeline will be exported. 

 

Reset Start/End 

Resets the Start & End so the all the available frames will be used for export. 

 

Set Current as Start 

Sets the current frame as the start frame. 

 

Set Current as End 

Sets the current frame as the end frame. 

 

  



Open Batch Processor 

Opens the Batch Processor window allowing for exporting multiple files at a time. (see next chapter) 

 

Start/Stop Export 

Will go through the specified frames and export to all the selected formats. 

The process can be aborted by hitting the button again during the export. 

 

Note that the separate black console window will print information on what is exported where. 

  



BATCH PROCESSOR 

 

 

The Batch Processor allows exporting multiple files without additional user intervention. 

In the middle of the Batch Processor window a list of files is shown with an overview of the most important 

settings. 

 

You can continue to load files into the main window, adjust settings to your liking and then add them to the 

batch queue. 

Double clicking on a line from the list in the Batch Processor window will load the file and it’s settings into the 

main window so you can edit it’s settings, after adjusting you can re-add it to the queue if needed. 

 

Load/Save Queue 

Loads/Saves the queue including all per-file settings to a text file. 

 

Add to Queue 

Adds the file and settings from the main window into the queue. 

 

Remove from Queue 

Removes the currently selected row from the queue. 

 

Start Processing Queue 

Exports all the files from the queue one by one. 

  



TOP MENU 

 

File > Install License 

Let’s you browse to a license file and installs it to be used for the next time the application is run. 

 

File > Manual License Installation 

In case the automatic license installation fails (for example due to user rights, or UAC settings), this outlines 

how to manually extract/copy the license from your email into the correct folder. 

 

File > Show License Info 

Shows if a license is installed and who it belongs to. 

 

File > Check for new version on startup 

Checks for the availability of a new version upon startup, if a new version exists a summary of new/fixed 

features is shown and an option to take you to the download page. 

Note that you will need a working internet connection for this. 

 

File > Recompress BPC files 

Allows you to recompress several BPC files, this can be useful to convert older files into the newer updated 

format with better compression ratios 

 

File > Fix Corrupted File(s) 

In case your file got corrupted this will attempt to fix it by analyzing it and rebuilding what it can into a new 

file. 

 

File > Exit 

Saves settings and exits the application. (same as clicking the X in the top right corner) 

  



Settings > Reload last used file at startup 

Toggle to reload the last used BPC file into the File tab when the program starts. 

 

Settings > Draw FPS 

Toggle to draw the framerate in the bottom of the viewport. 

 

Settings > Draw Memory/CPU usage 

Toggle to draw the memory and CPU usage in the bottom of the viewport. 

 

Settings > Don't enlarge video streams 

When ON the 2D video windows will not enlarge beyond the raw data size. 

When OFF the 2D video windows will proportionally stretch the content to match the window size. 

 

Settings > Warn for Low FPS Streams 

Will show a small system tray warning when detecting drawing is slower than the expected frame rate of the 

raw data stream. This can indicate your computer is too slow and may drop some frames to keep up. 

 

Settings > Warn for File Overwriting 

Toggle to warn for overwriting of existing files. 

 

Settings > Slow Down on Low Memory 

Toggle to slown down exporting when memory is low. 

Since the Windows OS uses caching while writing it is possible that a slow disk can cause the memory to fill up, 

slowing down in this situation can ensure extra stability on machines with little memory. 

 

Settings > DoubleClick 3D Viewport for Fullscreen 

When enabled enlarges the program to fullscreen when doubleclicking in the Live 3D viewport. 

 

Settings > Viewport Settings 

Opens a window that allows you to specify colors and drawing settings for the 3D viewport.  



Help > Downloads Page 

Opens your default browser and takes you to the Brekel download page. 

 

Help > Forum 

Opens your default browser and takes you to the Brekel forums. (hosted on Google Groups) 

 

Help > Kinect v2 Configuration Verifier 

Tries to start the Configuration Verifier (if you’ve installed the full SDK) which can help troubleshoot if your 

machine is capable of running a Kinect v2 sensor. 

 

Help > Microsoft Troubleshooting Guide 

Opens your default browser and takes you to the Microsoft Troubleshooting Guide page. 

 

Help > Microsoft Forum 

Opens your default browser and takes you to the Microsoft Kinect v2 forums. 

 

Help > About 

Shows the about window with version information. 

 

Note that the Help menu will contain extra links to plugins for reading the various export formats in 3D 

applications. 

  



HEADLESS MODE 

 

You can run the application in a headless mode, without a GUI, in case you only want to stream data to other 

applications with minimal overhead. 

To start in headless mode use “-headless” as one of the commandline options when starting the program, or 

use the start menu shortcut. 

Upon startup settings will automatically be used from the last known startup of the GUI. 

Furthermore the following commandline options are available to force particular settings: 

 

-edgeFilter 3 

Set strength of edge filter to help reduce unwanted points at edges 

 

-synchronizeStreams 0 

Toggle stream synchronization (0 for OFF, 1 for ON) 

 

-mirror 0 

Toggle mirror mode (0 for OFF, 1 for ON) 

 

-autoAlignWithFloor 0 

Toggle automatic alignment with the floor (0 for OFF, 1 for ON) 

 

-sensorPosition 0.0 1.1 2.2 

 Set sensor position where the 3 values are for X,Y,Z 

 

-sensorRotation 0.0 1.1 2.2 

 Set sensor rotation where the 3 values are for X,Y,Z 

 

  



-colorCompression 1 

 Set color compression mode (0 for Lossless, 1 for Lossy (JPEG)) 

 

-JPEGquality 75 

 Set JPEG quality level for Lossy (JPEG) compression, 1-100 

 

-pointCompression 1 

 Set color compression mode (0 for Lossless, 1 for Lossy) 

 

-ignoreRecordTriggering 

When used the app will ignore Record Triggering signals from other Brekel 

apps in Master mode. (By default the headless mode will be in Slave mode) 

 

 


